$re = '/\b[A-Z][a-zA-Z]*\b/m';
$str = 'Abc,ABC?AbC,Abc123, Abc_345, abc.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);