using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=;)\s*([^;.]*)(?=\.)";
string input = @"B. 1922, Naperville in the Chicago area; white; education: secondary; b/p.""";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}