$re = '/(?<=;)\s*([^;.]*)(?=\.)/';
$str = 'B. 1922, Naperville in the Chicago area; white; education: secondary; b/p."';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);