package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)\"\$\{[^}]*\}\"\s?`)
var str = `This is the first variable "${abc}" and this is the second variable "${def}"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}