re = /\"\$\{[^}]*\}\"\s?/i
str = 'This is the first variable "${abc}" and this is the second variable "${def}"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end