const regex = /\b(Movie)\b\h+((?:(?!\h+[SE]\d+\b).)*)(?:\h(S\d+\h+E\d+))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(Movie)\\b\\h+((?:(?!\\h+[SE]\\d+\\b).)*)(?:\\h(S\\d+\\h+E\\d+))?', 'gm')
const str = `Movie TOTO S09 E22 2022 Copyright
Movie TOTO S09 2022 Copyright
Movie TOTO 2022
Movie TOTO E22 2022
Movie a test movie`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}