re = /\b(Movie)\b\h+((?:(?!\h+[SE]\d+\b).)*)(?:\h(S\d+\h+E\d+))?/m
str = 'Movie TOTO S09 E22 2022 Copyright
Movie TOTO S09 2022 Copyright
Movie TOTO 2022
Movie TOTO E22 2022
Movie a test movie'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end