package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[1-9]{1}$|^[1-3]{1}[0-9]{1}$|^4{1}[0-5]{1}$`)
var str = `1
2
74
45
46
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}