$re = '/(?<=“)[^“”]*(?=”)|[^\s“”]+/m';
$str = 'add 2017-04-25 2 USD Jogurt
add 2017-04-25 3 EUR “French fries”';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);