re = /(?<=“)[^“”]*(?=”)|[^\s“”]+/m
str = 'add 2017-04-25 2 USD Jogurt
add 2017-04-25 3 EUR “French fries”'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end