$re = '/(?=([a-zA-Z]{2}))/';
$str = 'subhash chand
yobie chimwanachomama
riadh chaieb';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);