re = /(?=([a-zA-Z]{2}))/
str = 'subhash chand
yobie chimwanachomama
riadh chaieb'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end