#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^room \d+(?:\n(?!room \d|service prov).*)*\nservice prov.*(?:\n(?!room|exit).*)*\nexit$"
Local $sString = "room 31" & @CRLF & _
"name "Bob"" & @CRLF & _
"no TV outlet 49" & @CRLF & _
"exit" & @CRLF & _
"room 5" & @CRLF & _
"name "Ted"" & @CRLF & _
"service prov 10.1" & @CRLF & _
"outlet 49-50,52" & @CRLF & _
"exit" & @CRLF & _
"room 80" & @CRLF & _
"name "Alice"" & @CRLF & _
"outlet 49-50,52" & @CRLF & _
"dead outlet 1-20" & @CRLF & _
"exit" & @CRLF & _
"room 50" & @CRLF & _
"name "Tim"" & @CRLF & _
"outlet 49" & @CRLF & _
"exit" & @CRLF & _
"room 51" & @CRLF & _
"name "Sue"" & @CRLF & _
"service prov 10.2.0" & @CRLF & _
"outlet 49" & @CRLF & _
"exit"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")