# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^room \d+(?:\n(?!room \d|service prov).*)*\nservice prov.*(?:\n(?!room|exit).*)*\nexit$"
test_str = ("room 31\n"
"name \"Bob\"\n"
"no TV outlet 49\n"
"exit\n"
"room 5\n"
"name \"Ted\"\n"
"service prov 10.1\n"
"outlet 49-50,52\n"
"exit\n"
"room 80\n"
"name \"Alice\"\n"
"outlet 49-50,52\n"
"dead outlet 1-20\n"
"exit\n"
"room 50\n"
"name \"Tim\"\n"
"outlet 49\n"
"exit\n"
"room 51\n"
"name \"Sue\"\n"
"service prov 10.2.0\n"
"outlet 49\n"
"exit")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.