using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[01]*\.?[01]+";
string input = @"1010111
101011.11
0b1010111
152.35";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}