$re = '/[01]*\.?[01]+/m';
$str = '1010111
101011.11
0b1010111
152.35';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);