using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*\bhttps?\b).+$";
string input = @"http://www.domain.org
https://www.domain.org
Anything else that you wish Anything else that you wish https://www.domain.org
Anything else that you wish Anything else that you wish ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}