import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*\\bhttps?\\b).+$";
final String string = "http://www.domain.org\n"
+ "https://www.domain.org\n"
+ "Anything else that you wish Anything else that you wish https://www.domain.org\n"
+ "Anything else that you wish Anything else that you wish ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}