package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\smsg=)(.+)(,)`)
var str = `String str = "sourceType=Match, msg=Event yyuyu, test 1, usrPicture=null, friendCount=0";`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}