$re = '/(\smsg=)(.+)(,)/';
$str = 'String str = "sourceType=Match, msg=Event yyuyu, test 1, usrPicture=null, friendCount=0";';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);