package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^befghjklmpqrsuvwxyz]+$`)
var str = `ant
bee
cat
dodo
elephant
giraffe
horse`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}