re = /^[^befghjklmpqrsuvwxyz]+$/m
str = 'ant
bee
cat
dodo
elephant
giraffe
horse'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end