import re
regex = re.compile(r"^([#$%*& ])(?<name>[A-Za-z]+)\1=(?<length>[0-9]+)!!(?<code>.*$)", flags=re.MULTILINE)
test_str = ("Mike??Hailwood=5!![pliu\n"
"#SteveHislop#=16!!df%TU[Tj(h!!TT[S\n"
"*DavMolyneux*=15!!efgk#'_$&UYV%h%\n"
"RichardQ^uayle=16!!fr5de5kd\n\n\n\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")