const regex = new RegExp('^(?<title>.+?)(?:(?:[-_\\W](?<![()\\[!]))+S?(?<season>(?<!\\d+)(?:\\d{1,2})(?!\\d+))(?i:[ex]|\\W[ex]){1,2}(?<episode>\\d{2,3}(?!\\d+))(?:(?:\\-|[ex]|\\W[ex]|_){1,2}(?<episode>\\d{2,3}(?!\\d+)))*)(?:[-_. ]|$)', 'gm')
const str = `Frontline.S43E16.2000.Meters.to.Andriivka.1080p.WEB.h264-BAE`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}