re = /^(?<title>.+?)(?:(?:[-_\W](?<![()\[!]))+S?(?<season>(?<!\d+)(?:\d{1,2})(?!\d+))(?i:[ex]|\W[ex]){1,2}(?<episode>\d{2,3}(?!\d+))(?:(?:\-|[ex]|\W[ex]|_){1,2}(?<episode>\d{2,3}(?!\d+)))*)(?:[-_. ]|$)/m
str = 'Frontline.S43E16.2000.Meters.to.Andriivka.1080p.WEB.h264-BAE'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end