using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d(?!\d)|[xyz)])(?=[\w(])";
string input = @"888+(x+x)(xyz)+5(x+5)+5x5+5.5555+55x+x555cos(5x)+5sin(zx5)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}