$re = '/(\d(?!\d)|[xyz)])(?=[\w(])/m';
$str = '888+(x+x)(xyz)+5(x+5)+5x5+5.5555+55x+x555cos(5x)+5sin(zx5)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);