using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$";
string input = @"http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}