package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^http(?:s?):\/\/regex101\.com\/r\/([a-zA-Z0-9]{1,6})?$`)
var str = `http://regex101.com/r/mH1fN5
http://regex101.com/r/fW0vZ2`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}