using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ab(?!_?p)";
string input = @"ab
ab_b
ab_pm
ab_pn
c1_ab_b
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}