$re = '/ab(?!_?p)/m';
$str = 'ab
ab_b
ab_pm
ab_pn
c1_ab_b
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);