package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+\s+(\d+\s+-\s+([^\-\s]+(\s+[^\-\s]+)*))(\s+-.*)?$`)
var str = `Opcao 06 invalida - nao corresponde ao formato123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}