import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([a-z]*\\.[a-z]*|[a-z]+)$";
final String string = "abc\n"
+ "a.cd\n"
+ ".\n"
+ "a\n\n"
+ "Not:\n"
+ "a.a.a\n"
+ ".a.\n"
+ "..\n"
+ "a#a\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}