#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*[0-9])(?=.*[a-zA-Z]).*"
Local $sString = "^4_*!:%t`~" & @CRLF & _
"^t_*!:%4`~" & @CRLF & _
"^4_*!:%`~" & @CRLF & _
"^_*!:%t`~" & @CRLF & _
"^t_*!:%`~" & @CRLF & _
"^_*!:%4`~" & @CRLF & _
"^_*!:%`~"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")