using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*[0-9])(?=.*[a-zA-Z]).*";
string input = @"^4_*!:%t`~
^t_*!:%4`~
^4_*!:%`~
^_*!:%t`~
^t_*!:%`~
^_*!:%4`~
^_*!:%`~";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}