import re
regex = re.compile(r"^(\d+),([a-zA-Z]+(?: [a-zA-Z]+)*),", flags=re.MULTILINE)
test_str = ("Address Number,Name,Employee Master Exist(Y/N),Auto-Deposit Exists(Y/N),Supplier Master Exists(Y/N),Supplier Master Created,ACH Account Exists(Y/N),ACH Account Created,ACH Same as Auto-deposit(Y/N)\n\n"
"4398,Presley Elvis Aaron,Y,N,Y,N,Y,N,N\n"
"10154,Shepard Alan Barrett,Y,Y,Y,N,Y,N,N")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")