#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?<!since)(?:\s*)1\.0\.0"
Local $sString = "/**" & @CRLF & _
" * @since 1.0.0" & @CRLF & _
" * @package blah blah blah" & @CRLF & _
" * Version: 1.0.0" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * Fired during plugin activation." & @CRLF & _
" *" & @CRLF & _
" * This class defines all code necessary to run during the plugin's activation." & @CRLF & _
" *" & @CRLF & _
" * @since 1.0.0" & @CRLF & _
" * @package blah blah" & @CRLF & _
" * @subpackage blah blah" & @CRLF & _
" * @author blah blah" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"define( 'PLUGIN_VERSION', '1.0.0' );" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")