using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z]+(?: [a-zA-Z]{2,})*$";
string input = @"ed vu
edd v
e ldd
e li
e ei ed
e el ed uuu
e el elld liid eiii idid";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}