package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]+(?: [a-zA-Z]{2,})*$`)
var str = `ed vu
edd v
e ldd
e li
e ei ed
e el ed uuu
e el elld liid eiii idid`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}