package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b((?:[Ee]tc|St|Gen|Hon|Prof|Dr|Mr|Ms|Mrs|[JS]r|Col|Maj|Brig|Sgt|Capt|Cmnd|Sen|Rev|Rep|Revd|pp|[Vv]iz|i\.?\s*e|[Vvol]|[Rr]col|maj|Lt|[Ff]ig|[Ff]igs|[Vv]iz|[Vv]ols|[Aa]pprox|[Ii]ncl|Pres|[Dd]ept|min|max|[Gg]ovt|lb|ft|c\.?\s*f|vs|\p{Lu}(?:\.\p{Lu})+)\.)|[^0-9\p{L}]`)
var str = `F.B.I.Federal.Bureau.of.Investigation.Dr.Mannon`
var substitution = "$1 "
fmt.Println(re.ReplaceAllString(str, substitution))
}