$re = '/([\d.]*) . . \[([\w/]*):([\w:]*) [\+\w]*] \"[\w]* [\W\w\s]* *\"*(www.*\w*.*\w{2})* [\w\W]*\" (\w*) (\w*) \"[\w\W]*(https://www\.\w*\.\w{2})[\W][^\s]* *\" *\"([^\s]*) [(\W\w]([\w\W)]*)\) *([^\"]*)\)*[\w]*.*/m';
$str = '2.177.12.140 - - [22/Jan/2019:03:56:36 +0330] "GET /m/filter/b1,b103 HTTP/1.1" 200 4911 "https://www.zanbil.ir/m/product/33606/%D8%AA%D9%84%D9%88%DB%8C%D8%B2%DB%8C%D9%88%D9%86-%D8%A7%D9%84-%D8%A7%DB%8C-%D8%AF%DB%8C-%D8%B3%D8%A7%D9%85%D8%B3%D9%88%D9%86%DA%AF-%D9%85%D8%AF%D9%84-55NU8950-Ultra-HD-4K" "Mozilla/5.0 (Android 7.1.1; Mobile; rv:64.0) Gecko/64.0 Firefox/64.0" "-"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);