import Foundation
let pattern = #"([\d.]*) . . \[([\w/]*):([\w:]*) [\+\w]*] \"[\w]* [\W\w\s]* *\"*(www.*\w*.*\w{2})* [\w\W]*\" (\w*) (\w*) \"[\w\W]*(https://www\.\w*\.\w{2})[\W][^\s]* *\" *\"([^\s]*) [(\W\w]([\w\W)]*)\) *([^\"]*)\)*[\w]*.*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"2.177.12.140 - - [22/Jan/2019:03:56:36 +0330] "GET /m/filter/b1,b103 HTTP/1.1" 200 4911 "https://www.zanbil.ir/m/product/33606/%D8%AA%D9%84%D9%88%DB%8C%D8%B2%DB%8C%D9%88%D9%86-%D8%A7%D9%84-%D8%A7%DB%8C-%D8%AF%DB%8C-%D8%B3%D8%A7%D9%85%D8%B3%D9%88%D9%86%DA%AF-%D9%85%D8%AF%D9%84-55NU8950-Ultra-HD-4K" "Mozilla/5.0 (Android 7.1.1; Mobile; rv:64.0) Gecko/64.0 Firefox/64.0" "-""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)