// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?:.*?(\d+(?:\.\d+)?/[1-9]\d+)){2}").unwrap();
let string = "Happy 4/20 from the team! 13/10 congrats..after so many contents";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}