package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)"multipleChoice\\":\[\[.*\],\[.*?\],\[(true,false|false,true|true,true).*?\],\[(true,false|false,true|true,true).*?\]`)
var str = `"multipleChoice\":[[],[false,false,false,true,false],[true,false,true,false,false],[true,false,true,false,false],[false,false,true,false,false],[false,false,true,false,false],[false,false,true,false,false],[false,false,false,true,false],[],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false]]}",`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}