re = /"multipleChoice\\":\[\[.*\],\[.*?\],\[(true,false|false,true|true,true).*?\],\[(true,false|false,true|true,true).*?\]/m
str = '"multipleChoice\\":[[],[false,false,false,true,false],[true,false,true,false,false],[true,false,true,false,false],[false,false,true,false,false],[false,false,true,false,false],[false,false,true,false,false],[false,false,false,true,false],[],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false],[false,false,true,false,false,false]]}",'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end