package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[\u0000-\u007F]+|[\u0370-\u03FF]+)$`)
var str = `asdf αα
αα
abc
ął`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}