$re = '/^(?:[\u0000-\u007F]+|[\u0370-\u03FF]+)$/m';
$str = 'asdf αα
αα
abc
ął';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);