$re = '/^\d{4,6}$/m';
$str = '50532
201
20.02
53d24
465a5
502356
503543546';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);