import re
regex = re.compile(r"^\d{4,6}$", flags=re.MULTILINE)
test_str = ("50532\n"
"201\n"
"20.02\n"
"53d24\n"
"465a5\n"
"502356\n"
"503543546")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")