package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\d{4}|\d{6})$`)
var str = `50532
201
20.02
53d24
465a5
502356
503543546
1234
21321`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}